Index > Scribe > https:// issue in v1.87 (Test1, Win32 Release)
Author/Date https:// issue in v1.87 (Test1, Win32 Release)
Carlos Rocha
05/01/2004 8:55am
Hi Matthew,

I dont know if it's new to 1.87, but URLs starting with https:// don't become a link, and I still receive some HTML messages that don't let me "View in browser". It's possible to add that option to ALL messages, even text?

Thanks and good job
05/01/2004 6:46pm
Are you using the linux or windows build?
Carlos Rocha
05/01/2004 7:43pm

XP Pro
05/01/2004 7:54pm
Well https links being clickable is different for HTML messages as opposed to text messages.

In text mode the https link is made clickable and passed to ShellExecute when you click it. So if your Windows doesn't know what to do with https it won't work.

If your viewing the mail in HTML mode then the https link has to be in a anchor tag to be clickable otherwise you'll have to select the text and paste it into a browser.

To tell whether your viewing the email using the text or html control, right click on the body and if the menu has "view in default browser" then your using the HTML control otherwise your in the text control.

You said that "View in default browser" only works sometimes, what happens the other times?
Carlos Rocha
06/01/2004 8:05pm
In the other times, I dont have that option (because is a text message). Maybe if we can have the option to "View in default browser" in text messages...

(I forwarded to you the html message that I received, but the lines format are wrong)
07/01/2004 4:37am
I'm not sure what the point of viewing text in the default browser is.

I've fixed a issue with HTML text layout. Maybe this is good enough? We'll see when you get the next version.