Index > Scribe > Can't get Scribe to accept the SSL plug-in
Author/Date Can't get Scribe to accept the SSL plug-in
14/03/2005 12:45am
I'm quite new to i.Scribe 1.87 (final) and I can't get it to accept the SSL plug-in (v0.40) and I'm unsure why. I keep getting this: "ScribePlugin load log: Operating system couldn't load the library file (.DLL/.SO) Failed." I've tried placing the file in the program's directory and various subdirectories, but every time I try to add it to my plug-in dialog, I get an error. I have "libeay32.dll" and "ssleay32.dll" in a directory entitled "OpenSSL." Any ideas?
14/03/2005 1:36am
The plugins only work with the latest version of Scribe :(
14/03/2005 2:32am
Thanks for the reply. This is very bizarre since I have the latest stable build. Are you sure about this? Does this mean that we're expected to use the beta builds? How stable are they?
14/03/2005 3:09am
Update: I now have the latest i.Scribe but something's not right. When I try to check my Gmail account (which IS set for POP3), I get this message in my log: "Error: Scribe_SSL.cpp:296 - SSL_CTX_new failed." Ideas?
14/03/2005 3:39am
And openssl is installed?
14/03/2005 3:41am
The test builds are pretty stable.
14/03/2005 3:44am
No, actually. Following the guideance from the SSL plug-in page ("With the release of v0.4 of the SSL plugin you can install the required parts of OpenSSL into '..\OpenSSL' relitive to the location of Scribe.exe and the plugin will find and use them"), I downloaded the files online from, created a subdirectory entitled "OpenSSL," and placed them in there (with copies in my i.Scribe root for good measure).

Here's how my directory tree appears right now:

| about.html
| CrashData.txt
| Lgi.dll
| LgiNet.dll
| LgiSkin.dll
| libeay32.dll
| mail.mail2
| Scribe.exe
| Scribe.lr8
| scribe.r
| Scribe.txt
| ScribeMapi.dll
| Scribe_SSL.dll
| ssleay32.dll
| Title.gif
| title.html
| uninstall.exe
| _about.gif
| _icons.gif
| _toolbar.gif
| [HTML files removed for space's sake]
14/03/2005 4:26am
When I place the two DLLs in the program root directory, I don't get an error message but I get no connection either. When I place them in the OpenSSL directory, I get the DLLs-not-installed error. Since the documentation states that the files are to be in the OpenSSL directory, I'll leave them there, but that leaves me with this curious error message.

Might I have the wrong versions of the files? Here are the stats of the files I downloaded:

12/01/2002 01:57 PM 593,920 libeay32.dll
11/02/2004 06:21 PM 472,336 ssleay32.dll

They were downloaded from and

i.Script looks very interesting thus far! I just hope I can get this to work.
14/03/2005 5:11am
You have the OpenSSL directory in a siub-folder of the Scribe directory. Which is not right, it should be next to the Scribe dir:

| |
| +-Help
14/03/2005 5:34am
Ah, I see. Well, I made OpenSSL a sibling directory to Scribe and tried adding the SSL plug-in again. I still get the same errors!

Current tree from "C:\Documents and Settings\Laptop User\My Documents\=new=\i.Scribe\Scribe":
15/03/2005 2:28am
I'm having a similar problems with the plugin. With the dlls located in an OpenSSL folder next to Scribe (or inside Scribe's folder) the program starts up with the 'dlls not installed' message. When the dlls are placed in Scribe's root folder this is the log I get;

Connected to '' using SSL
+OK BAYC1-PAPOP02 POP3 Server ready
USER b1xxxxxx
PASS *******
-ERR command failed
SSL connection closed.

Would be nice to get this fixed soon; my primary mailbox is now inaccessible through InScribe!
15/03/2005 3:57am
Success at last! It's now working (send & receive) with the two dlls in the Scribe directory. I downloaded the latest OpenSSL installer (Win32OpenSSL-v0.9.7e.exe) and extracted the dlls instead of using 'generic' ones; the sizes are;
libeay32.dll at 843,776 bytes (modified Oct. 26 2004)
SSLeay32.dll at 159,744 bytes (modified Oct. 26 2004)
Hope this helps!
15/03/2005 4:18am
Sounds great, BAR. Any chance you can e-mail those files to me or something? I don't care to install the program solely to get these files.
15/03/2005 4:24am
Oh, cancel that. I did a nice Google search and found a directory ( with both files. Installing them directly into my i.Scribe directory did the trick! Finally, I'm set! And hopefully this post will help others.