Index > Scribe > Can't get scribe to run. Can you help?
Author/Date Can't get scribe to run. Can you help?
12/10/2003 4:29pm
Using Suse 8.0 plus upgrades.
Using KDE desktop, and Galeon browser
Not very good at installing software, usually defeats me.
Downloads from your site ok.
decompress it ok into component files, click on run scribe script file, nothing happens.
Ok so use run box from menu, type "scribe" in the box and click on run, error message is "could not run the specified command"
Do you have to move first as per readme?

12/10/2003 6:58pm
from a term:

ldd ./scribe

should list all the dependencies and whether they are present or not. You can paste the results into this thread for me to see if you want.
13/10/2003 7:50am
Tried to do as you said.
No such file or directoy was the result.

Also, decompressed the download and then clicked on run scribe which only opened the script file in Kwrite
13/10/2003 8:04am
Well you have to run that command from the directory that Scribe is residing in. i.e.
cd /SomePath/iScribe
ldd ./scribe

The "./" is just the current directory.

Also try in a term:
cd /SomePath/iScribe

And see what it does.

Maybe the permissions on the run-scribe file are incorrect.
cd /SomePath/iScribe
ls -la ./run-scribe

To set the permissions:
cd /SomePath/iScribe
chmod 700 ./run-scribe

13/10/2003 3:53pm
Sorry was not in the right directory

linux:/home/scribe-linux # ldd ./scribe => /lib/ (0x40028000) => /usr/X11R6/lib/ (0x4003e000) => /usr/X11R6/lib/ (0x40043000) => /usr/X11R6/lib/ (0x40051000) => not found => not found => /usr/lib/ (0x40112000) => not found => not found => /lib/ (0x40152000) => not found => /lib/ (0x40176000) => /lib/ (0x4029e000)
/lib/ => /lib/ (0x40000000)

So presumably I need the dependencies not found here.

And once I have installed them it should run ok?
13/10/2003 6:11pm
Once these are installed then things should work fine.

Firstly, a note on libXft and libfontconfig, these 2 libraries are becoming the standard for font display under Linux, some apps, like Scribe, are starting to require them as opposed to falling back to X11 fonts. These dependencies are listed on the freshmeat page for Scribe.

libLgi is an internal library that comes in the Scribe download. The "run-scribe" script will map the appropriate paths to make sure Scribe can find it. So don't worry about that.

The libstdc++ and libgcc_s are not generated by me but by the compiler linker so I don't have any control over them. But I will try and investigate why some distro's don't seem to have them.
13/10/2003 6:19pm
It looks like libstdC++ and libgcc_s are part of the gcc3 package, so if you install gcc3 then those libraries will probably be installed with it, solving that part of the problem.

Most other modern distros ship with gcc3 nowdays so it's doesn't seem unreasonable to require a gcc3 system.
14/10/2003 12:07am
I've worked out how to remove Scribe's dependency on libgcc_s, by statically linking it in. This adds 24k onto the executable size but thats worth it for one less dependency don't you think?

Also hunting around on the net a found this page that talks about getting applications that require to work on Suse. Maybe it will be helpful for you.
17/10/2003 5:24pm
I appreciate your help, it explains why I failed to get libstc++ working in the past on Suse to get abiword upgrade working.
I would dump suse tomorrow if i could figure out how to get debian running properly.
02/11/2003 11:18pm
I've removed the dependency in the latest release. The others (xft, fontconfig and I don't have much control over.