Index > Scribe > Unhandled exceptions
Author/Date Unhandled exceptions
25/11/2002 6:48am
I installed v1.84 of i.Scribe on a win2k machine with a DSL connection. After configuring it for IMAP/SMTP I created and tried to send a message to myself, telling the kerio firewall this app could permanently access the net when it complained.

My message didn't get sent, it got put on a queue. Since I didn't see any obvious menu item to control this I exited and restarted the program. After that I always get a popup about default mail clients and then the following error whenever I start i.Scribe:

Unhandled Exception
Code: c0000005

Call stack:
004469AB: E:ScribeScribe.exe Offset: 0xA962 (ListAddr::GetVariant)
77E96523: E:OSsystem32KERNEL32.dll Offset: 0x13 (CreateThread)

i.Scribe then crashes whether I select yes/no/cancel. I copied the error text from crashdata.txt. Exact same values every time.

I'm able to run outlook express, calypso, pegasus, mail warrior etc. with no problems.
25/11/2002 4:36pm
There is a build of v1.85 with debugging symbols here but it's 2mb...

However it does give more accurate crash reports that help me work out where the crash is.

Anyway it's there if you want to help out.

25/11/2002 8:39pm
I deleted v1.84 and installed the debugging version. I also copied your msvcrtd.dll to my system32 directory. My version of msvcrt.dll (no 'd') is 6.1.8924.0. My email provider ( supports POP3 and IMAP, although I
normally use the latter since they are so IMAP-centric.

I can appear to send a email to myself using POP3, with no problems. When I reconfigure for IMAP and try to forward the
email to myself it shows up in the OutBox. I get the following exception the next time I start i.Scribe.

Unhandled Exception
Code: c0000005

Call stack:
00481253: E:ScribeScribe.exe
10020627: E:Scribelgi.dll Offset: 0x2757 (ResFactory::Res_Write)
780060CE: E:OSsystem32MSVCRT.DLL Offset: 0x69F (_unDNameEx)
77E96523: E:OSsystem32kernel32.dll Offset: 0x13 (CreateThread)

There is no scribe.txt file. Since I have DSL its no problem for me to try other debugging versions etc. if that will help.
25/11/2002 10:12pm
Oh you want it fixed!


Well try this one then.
25/11/2002 10:15pm
Oh, sending is completely separate to receiving, so you need to keep your SMTP server in the send tab. Even when using IMAP to receive mail.

If you have any furthur trouble with IMAP let me know.
26/11/2002 5:03am
Thanks for the quick responses. Very refreshing. I still have IMAP problems, but the create thread problem is gone.

1. I wiped the prior version and installed the new one. Double checked I had selected IMAP in the mailbox type field and sent a message to myself. I hit <receive> a couple of times, getting nothing. The next four times I hit <receive> I got a copy of the message I had sent. (sent one message, got four copies of it) I then went to calypso (my default email client) and checked for new email. I got one copy (unread) of the message. Checked again, nothing.

2. I then logged onto the yahoo web page and sent my fastmail account another email message. I got only one copy in i.scribe no matter how many times I hit <receive>. I then switched back to calypso and told it to check email - I got one copy (unread) of the email sent from yahoo.

3. I then verified that I did NOT check "leave messages on server" in the account/receive screen in i.Scribe. I also logged into fastmail (the email provider) using thier web mail interface and verified nothing looked funny there.

I also went back and checked the headers for the first four copies in i.scribe and the single copy in calypso of the single message I sent in step 1. They appear to have identical timestamps and SMTP id's in the message headers. The field tab in i.scribe reports that the four messages receive date was different (different second count), as expected.

4. Exited i.scribe. I then created a message in calypso, sent it to myself and quickly exited calypso. Started up i.scribe. Every single time I pressed the <receive> key I got a copy of the single message. I exited i.scribe and started up calypso. I got a single copy of the message (unread). Checked for new mail again, no more email. Exited calypso.

5. I used a hex editor to look at the values after "LeaveOnServer" in scribe.r. The values are 4C 65 61 76 65 4F 6E 53 65 72 76 65 72 00 01 00 00 00 00 00 00 00 0D 00 That isolated '1' made me wonder if the checkbox setting got saved correctly. So I checked the "leave on server" checkbox in options, and sent myself another message. I got only one copy no matter how many times I hit <receive>. Great. However, I then started up calypso and it also got a single copy (unread) of the message. So I don't think its as simple as a flipped checkbox setting.

6. I then unchecked the leave on server checkbox, changed the "don't download email larger than " from its default value (0) to 600, and sent another email to myself. No difference - get multiple copies etc. I selected the "preview mail on server" menu item. It displays a single copy of the last message I sent, and <download> is not grayed out. Pressing it has no effect, I can still get multiple copies of the message.

In case its not obvious I like i.scribe.
26/11/2002 5:15am
Oops. The forum software appears to have silently deleted all of my references to the Receive key because I surrounded that token with angle brackets (a convention I'm used to). I wasn't paying attention to whether your forum accepted only text or also accepted html, or I would have realized what would happen when it sees an invalid html tag. Sorry about that, hope its still readable.
26/11/2002 6:28am
I took the liberty of fixing the brackets so I can read the post.. :)

I should put a checkbox on the post script for HTML or plain text... so much to do, so little time.
26/11/2002 7:01am
Well if you liked the last version your going to love this (I hope!).

And this time with extra working zing!

(don't mind me it's late and I'm tired)

Things like "not receiving mail properly" get high priority fixes. So thanks for the timely responses.

The imap problems are because I've been using the existing imap code to build a full online imap implementation, which is 90% there. It's slated for a v2 release in the next few months. But I broke a few things working on that, now it should work like it used to.
26/11/2002 11:02pm
Looks great. All of the problems I had seen appear to be fixed. I've tried a lot of the basic email functionality I use - even sending a mail message with a .doc attachment seems to work fine. The document looks identical, no change in the formating.

Pushing my luck, I tried configuring for SSL (IMAP port 993, SMTP port 465). This caused a new mail I tried to send to stay in the outbox. I deleted it and then tried to reconfigure - it refused to let me because it claimed it was in the middle of reading! I worked around this by exiting and restarting i.Scribe. No big deal.

I then changed the port assignments to 143 and 25 (the default values, but wanted to verify i.Scribe worked with explicit port settings) and things were back to normal.

I suspect you don't support SSL (couldn't find any mention of it) but it cost nothing to try it :)
26/11/2002 11:36pm
I don't support SSL yet, just havn't got around to it.