Index > Scribe > SSL Libs missing V2.2.14
Author/Date SSL Libs missing V2.2.14
29/05/2018 3:21am
I have just updated my portable version from 2.2.9 to 2.2.14.
In 2.2.9 SSL was working, now after the update it is NOT working.
The report when checking mail is "openSSLSocket.cpp:297 - SSL Libraries missing".
The offers to 'Install' then 'error not available.
Works very well on non SSL.

Please advise how to fix.
29/05/2018 10:08am
You can manually download and install the SSL libraries from here. Just put them in the same folder as your Scribe install. I'll have a look at why the auto-install isn't working when I get a chance.
29/05/2018 6:57pm
Hello fret,
Thank you for your reply.
Downloaded as directed, put into install folder, but still get the exact same result, as mentioned above.
29/05/2018 7:29pm
Further to the above, I decided to do a completely 'fresh' install on another USB stick.
Went through the install process for portable, opened the program, set it up for 1 x mail account requiring SSL.
The program attempted to contact the account mail server.
Result the report stating the required files were missing albeit that I had already placed them in the folder.
Not being a 'techie' I can only assume that in the last update, something has either changed or caused something else to change within the program, as it seems it cannot access the 2 x dll's needed.
Over to you.
Thanks for your continued support.
30/05/2018 12:19pm
Oohh you're probably using the 32bit build right?

...yeah I'll need to find the right DLLs. The ones I linked are 64bit.
30/05/2018 2:38pm
Hi Fret,
Your link and the subsequent downloaded files are;


30/05/2018 2:58pm
Hi Fret,
Your link and the subsequent downloaded files are;

That didn't answer my question, are you using the 32bit build of Scribe?
30/05/2018 7:16pm
Hi Fret,
My apologies - yes I am using the 32 bit version.
04/06/2018 9:01am
I've posted 32bit SSL libraries to the components website. You should be able to install them from within Scribe now.
Raymond Foster
04/06/2018 9:33am
Hi Fret,
Perfect - now works a treat.
Many thanks for your labours.