Index > Scribe > Spell Check
Author/Date Spell Check
Neil R
03/11/2015 7:37pm
Can't get spell check to work in iscribe-win32-v2.1.1. Can't change Language (0) or Dictionary (0) in File-->Options-->Other (Spell Check: true).
04/11/2015 9:50am
I think there are some files missing in the installer script. I will investigate and fix it today.
06/11/2015 5:54pm
Please try v2.1.2, it should work now. I've made some fixes, and done some testing on a clean windows install. At least the English works. You won't get to select a dictionary yet, but the language works.
Neil R
06/11/2015 9:35pm
Thanks, but after installation I seem to have Inscribe rather than i.scribe? Can I toggle to i.Scribe or does it use a different installer?
07/11/2015 8:01am
I had originally uploaded the wrong file. But yesterday I fixed the build available on the InScribe site. Please clear your cache in the browser and re-download it. Sorry about the confusion.
Neil R
08/11/2015 7:36am
All good now. Thank you.
08/11/2015 1:04pm
I'm getting every word flagged as a spelling error.
09/11/2015 7:29am
I'm getting every word flagged as a spelling error.
Which language did you select in the options?

If you open the console (Tools -> Open Console) is there anything specific to Aspell in there? (Maybe copy and paste the whole log if you're not sure and send it to me.)
09/11/2015 1:26pm
I hadn't set the language to English (the drop-down seems finicky).
After I did that, I'm getting the following error:

.\Code\SpellCheckAspell.cpp:217 - ASpell failed to create 'C:\appsx86\Memecode\Scribe\Aspell\dict'
Aspell Checker: No word lists can be found for the language "el".
.\Code\SpellCheckAspell.cpp:217 - ASpell failed to create 'C:/appsx86/Memecode/Scribe/Aspell/dict/el'
.\Code\SpellCheckAspell.cpp:737 - Failed to create 'C:/appsx86/Memecode/Scribe/Aspell/dict/el'.

The appsx86 folder requires Admin privileges to create directories / files. That's likely a problem. When I launch InScribe with admin rights, I get the following error:

Aspell Checker: No word lists can be found for the language "el".
09/11/2015 1:32pm
After restarting InScribe, ASpell appears to be working. (I think had accidentally set it to Greek.)
It might need to be run with admin rights in order to create the necessary folders first, though.
09/11/2015 1:45pm
It might need to be run with admin rights in order to create the necessary folders first, though.
It shouldn't. Currently the (aspell glue) code thinks it's running in "portable" mode and trying to create the required folders in the same location as the program, but in reality it's running as a Desktop install and doesn't have the rights to modify the folders in it's install location.

The desktop/portable mode is generally derived from the options file location. If it's the same as the install location then it's a "portable" install. If it's in c:\Users\(username)\AppData\Roaming\Scribe then it's a "desktop" install. I'm guessing there might be an unrelated bug in determining the current mode. The first couple of lines in the console will report what mode Scribe thinks it's in.
10/11/2015 11:59pm
It looks like it has selected portable mode:

Selecting portable mode based on options file path.
11/11/2015 9:45am
It looks like it has selected portable mode
You'll need to manually move the data files from your Scribe folder to the AppData folder:

If it doesn't exist then create it. The file/folder you need to move are:
- ScribeOptions.xml
- Folders.mail3
- spamwords.idx (if it exists)
- hamwords.idx (if it exists)
- whitelist.idx (if it exists)

Also copy the Aspell folder from the install folder over to the AppData folder. That should convert the install to a "Desktop" install where the spell check works correctly. This may have happened when you installed an older build that didn't really do the desktop/portable thing correctly at the installer level.