Index > FileTeePee > New bug introduced in i.FTP 1.80?
Author/Date New bug introduced in i.FTP 1.80?
25/05/2004 10:58am

A new problem apparently introduced in 1.80:
Some FTP servers make i.FTP crash or stop responding when using passive mode.

After sending PASV I get a "227 Entering Passive Mode" message, which is ok.
Then iFTP sends: LIST -l
Nothing happens for 3 or 4 seconds and then this message appears in log:
Information: [Data] Cannot assign requested address.

At first I thought it was a problem in my LAN, since it worked when using active transfers... but I remembered it worked fine in 1.77, so I tried... and yes, it works fine with i.FTP 1.77.

I tried with 1.80 and I got the same error I get with 1.81.

A server which causes this problem:

Greets and please, don't hate me :)
25/05/2004 7:32pm
I saw that as well. So what I'll do is look at the changes in the code since 1.77 and see if there is anything obvious in the networking code that could cause this.
26/05/2004 3:06am
I've fixed the normal passive connect to say a unix server. But the passive connect to a M$ server is still broken. This should all right considering that M$ has a buggy implementation for passive connects in at least some versions of their FTP server. So I'm happy the issue is resolved.

I'll test it on Win32 and post a new build soon. My current testing has been on Linux.
26/05/2004 8:17am
Aha, so passive mode will work as it did in 1.77, I guess :) Great!
By the way, do you know where to get some info about this bug in M$ servers? Admins of the site I told you to test with are interested on fixing this issue.
Dobule thanks!
26/05/2004 10:14am
Check this out.
26/05/2004 10:14am
Actually you want to use active mode. It's an option in the connection dialog.
26/05/2004 10:41am
Thanks! :)
Hmmm... that bug is in IIS for WinNT and they are using Win2000... oh well, nevermind!
26/05/2004 10:57am
Well it matches the symptoms pretty well and it's what Google turned up with a few quick searches.

And FWIW other ftp clients get the same result:
< 220 sva05 Microsoft FTP Service (Version 5.0).
> USER vendor
< 331 Password required for vendor.
> PASS *****
< 230 User vendor logged in.
> REST 1
< 350 Restarting at 1.
> REST 0
< 350 Restarting at 0.
< 215 Windows_NT version 5.0
< 257 "/vendor" is current directory.
~ Login completed.
< 227 Entering Passive Mode (*****************)
< 200 Type set to A.
< 426 Connection closed; transfer aborted.
~ Could not retrieve directory listing for "/vendor/"
26/05/2004 4:35pm
Their server is supposed to have all needed patches... bah, I guess that's what they get for using M$ poorly written software.
I'll tell them to install Matt's Linux distro when it's available :D
Thank you very much