Index > Scribe > 2 things that i dont like in i.Scribe
Author/Date 2 things that i dont like in i.Scribe
Carlos Rocha
20/08/2003 5:51pm
Only 2 things, all the rest is great:

First, when I click in the help to go to Scribe Homepage, it opens IE, not my default browser (Opera 7) and i'm trying not to use Microsoft software other than Windows.

Second, when I click in Scribe icon in desktop a second time, Scribe opens again, but don't let me use the same db file.
20/08/2003 7:21pm
1) All I do is pass the URL to ShellExecute, and windows decides to open IE. It has nothing to do with Scribe. (Sorry)

2) I'm going to add an option to restrict Scribe to one instance, which will solve the issue of 2 copies of Scribe running. Generally you only want 2 instances when there openning separate folders (ie 2 different users). I'm aware of this issue and will address it in the next release.
Carlos Rocha
20/08/2003 7:58pm
Thanks for the fast reply.

About the 2nd point, in fact, what concernes me is that I call scribe from another app, with command line parameters. Do you think the second call to scribe will accept these paramaters?
20/08/2003 8:03pm
Currently Scribe already detects another instance of itself and passes any command line parameters over to the running instance using shared memory.

When there are no parameters it just starts up normally.

What I propose is an option to just quit when there are no parameters and there is another instance running.
Carlos Rocha
21/08/2003 5:13pm
Still the 1st point:

When viewing an html message, the right click menu brings the option "View in default browser", and it really does...
By the way, any chances to translate that menu?
22/08/2003 9:42am
Up until recently I couldn't add translation entries for strings in LGI rather than Scribe. However recently I made a system for doing so. There are still some strings in LGI that are not set up to be optionally translated.

The HTML control's strings have not been setup for translation yet, but I will do that for the next release.
Carlos Rocha
23/08/2003 3:03am
Ok to the translations, but "View in default browser" opens the default browser, not IE... am I missing something?
It's not important, but I really hate IE...
23/08/2003 4:52am
I use Opera too as my default browser and I don't have this problem. Could it be, Carlos, that, although you named Opera your default browser, you forgot to select for which fileformats Opera is to be your default browser? (Check this out in Opera with Alt-p and then select 'default browser'. There you will be able to select a boxes for .html, .htm, .http etc.)
01/11/2003 2:42pm
I had the same problem and fixed it this way: Opera takes over almost all of your settings BUT what it doesn't do is change the "url open with..."
You have to do this manually. Go to my computer/view/options and change the extensiontype URL to open with Opera.