First Last Prev Next    No search results available      Search page      Enter new bug
Bug#: 60
Product:
Component:
Status: RESOLVED
Resolution: FIXED
Assigned To: Matthew Allen <fret@memecode.com>
Hardware:
OS:
Version:
Priority:
Severity:
Reporter: Matthew Allen <fret@memecode.com>
Add CC:
CC:
Remove selected CCs
URL:
Summary:

Attachment Type Creator Created Size Actions
Create a New Attachment (proposed patch, testcase, etc.) View All

Bug 60 depends on: Show dependency tree
Show dependency graph
Bug 60 blocks:

Additional Comments:







View Bug Activity   |   Format For Printing   |   XML   |   Clone This Bug


Description:   Opened: 2005-11-22 00:36
When polling the server with a pop3 protocol and the option 'leave messages on 
server' activated the server locks the eml file.
A empty message appears in the inbox (no sender,subjects,size,date).
the eml file in the user folder cannot be opened by (say:) wordpad.
MstIsUsedBy.exe claims mcserver.exe is locking the eml.

------- Comment #1 From Matthew Allen 2005-11-22 00:36:43 -------
*** Bug 50 has been marked as a duplicate of this bug. ***

------- Comment #2 From Matthew Allen 2005-11-22 00:40:04 -------
I fixed the "LIST" command to make pop3 preview work. I've also fixed the mail
RETN command to seek the file back to the start so that it doesn't send an empty
message.

------- Comment #3 From Matthew Allen 2005-11-22 00:42:50 -------
I've also made it close the file after it's done with it.

------- Comment #4 From exosceleton 2005-11-22 09:28:25 -------
the server cannot handle the read (or unread) flags correctly.
if there is read mail on the server, new emails are allso set read and will not 
be downloaded on a receive click.
a preview will show the second mail (as read)

when in the preview the section 1 message is set unread, all messages are set 
unread, and downloaded next recieve. (the first message apearing twice in the 
inbox since there was 1 already)

------- Comment #5 From exosceleton 2005-11-22 10:13:27 -------
here allso, i could make a screen recording

------- Comment #6 From Matthew Allen 2005-11-22 20:58:29 -------
Ok, so there was more than just one problem. The read/unread status problem was
caused by the UID's of the messages all being "0"... hardly unique. So thats
fixed now.

------- Comment #7 From exosceleton 2005-11-23 08:09:20 -------
seems fixed now (new scribe build and server0.81)

First Last Prev Next    No search results available      Search page      Enter new bug