First Last Prev Next    No search results available      Search page      Enter new bug
Bug#: 395
Product:
Component:
Status: RESOLVED
Resolution: FIXED
Assigned To: Matthew Allen <fret@memecode.com>
Hardware:
OS:
Version:
Priority:
Severity:
Reporter: Thomas Deharde <thomas@dehar.de>
Add CC:
CC:
URL:
Summary:

Attachment Type Creator Created Size Actions
Create a New Attachment (proposed patch, testcase, etc.) View All

Bug 395 depends on: Show dependency tree
Show dependency graph
Bug 395 blocks:

Additional Comments:







View Bug Activity   |   Format For Printing   |   XML   |   Clone This Bug


Description:   Opened: 2012-09-05 09:32
Concerns v2.00 beta40
When loading emails, the year in the "Date Sent" information is not correctly
shown in the column. I either get years dating 2005 or 2026. If you "export"
the mail via drag&drop to the desktop and open it with a text editor, you see
that the dates/years in the email are okay, so it's a matter of reading the
email. Not really a major bug since the emails are okay, but annoying, because
sorting by date is then messed up.
This bug does not appear in v2.00 beta38

------- Comment #1 From Matthew Allen 2012-09-06 00:08:02 -------
There are a few things I'd like to know to help reproduce this. I may have
indeed fixed the issue in the last few weeks. Because it seems familiar.

1) what is the "Date Format" setting in Options -> Appearance?

2) Secondly what is your computer's timezone set to? (Windows Date and time
settings -> change time zone)

3) What mail storage are you storing your email on? (Mail2, Mail3, or IMAP)
File -> Manage Mail Stores should tell you.


Then I'll try and reproduce it and see what can be done to fix it.

------- Comment #2 From Thomas Deharde 2012-09-06 20:10:51 -------
(In reply to comment #1)
> There are a few things I'd like to know to help reproduce this. I may have
> indeed fixed the issue in the last few weeks. Because it seems familiar.
> 1) what is the "Date Format" setting in Options -> Appearance?
> 2) Secondly what is your computer's timezone set to? (Windows Date and time
> settings -> change time zone)
> 3) What mail storage are you storing your email on? (Mail2, Mail3, or IMAP)
> File -> Manage Mail Stores should tell you.
> Then I'll try and reproduce it and see what can be done to fix it.

Okay, I think I got it nailed down:
Bug is not affected by "Date Format" or the Windows date and time settings.
However, the bug appears with the Mail2 format. It does not happen with the new
Mail3 database format.

------- Comment #3 From Matthew Allen 2012-09-06 22:21:53 -------
This is already fixed in beta41.

First Last Prev Next    No search results available      Search page      Enter new bug