First Last Prev Next    No search results available      Search page      Enter new bug
Bug#: 241
Product:
Component:
Status: RESOLVED
Resolution: FIXED
Assigned To: Matthew Allen <fret@memecode.com>
Hardware:
OS:
Version:
Priority:
Severity:
Reporter: Janusz Wisniewski <bugzilla@jbw.pl>
Add CC:
CC:
URL:
Summary:

Attachment Type Creator Created Size Actions
Create a New Attachment (proposed patch, testcase, etc.) View All

Bug 241 depends on: Show dependency tree
Show dependency graph
Bug 241 blocks:

Additional Comments:







View Bug Activity   |   Format For Printing   |   XML   |   Clone This Bug


Description:   Opened: 2010-02-24 14:12
LgiRes rejects "Shortcut" property, so the file is damaged on save.

IMO LgiRes should not delete unsupported elements, rather leave it intact.

BTW, is it necessary to have duplicated definitions, like IDS_1371?
Such twins are pretty far away from each other, so translator can easily
introduce unwanted differences. Unfortunately, LgiRes does not distinguish
these strings and makes them equal on save. And (according to Murphy's law)
always the worse string supersedes the better one.

IMO if equally labeled strings have different values LgiRes should at the very
least emit warning instead of silently overwrite them.

------- Comment #1 From Janusz Wisniewski 2010-02-24 14:16:13 -------
To reproduce this issue, just load Scribe.lr8, save it under different name and
compare files with WinMerge.

------- Comment #2 From Matthew Allen 2010-02-24 22:29:10 -------
(In reply to comment #0)
> LgiRes rejects "Shortcut" property, so the file is damaged on save.

This has already been implemented in my local build. I just need to make a
release of the changes I've made since the last release.

> IMO LgiRes should not delete unsupported elements, rather leave it intact.

This would require I change the underlying data structures that LgiRes uses,
and that would take a non-trivial engineering effort. Something I'm not willing
to embark on right now.

> BTW, is it necessary to have duplicated definitions, like IDS_1371?
> Such twins are pretty far away from each other, so translator can easily
> introduce unwanted differences. Unfortunately, LgiRes does not distinguish
> these strings and makes them equal on save. And (according to Murphy's law)
> always the worse string supersedes the better one.

This is a bug.

------- Comment #3 From Matthew Allen 2010-02-24 23:08:33 -------
http://memecode.com/data/lgires-win32-v192.exe

First Last Prev Next    No search results available      Search page      Enter new bug