Bug 415 - Filesize of sent mails with attachment is not correct
Bug#: 415 Product:  i.Scribe/InScribe Version: v2.00 beta40 Platform: PC
OS/Version: Windows 7 Status: RESOLVED Severity: major Priority: P1
Resolution: FIXED Assigned To: fret@memecode.com Reported By: thomas@dehar.de
Component: Email Functionality
URL: 
Summary: Filesize of sent mails with attachment is not correct
Opened: 2012-10-26 07:22
Description:   Opened: 2012-10-26 07:22
When you sent out an email with an attachment, the file size shown does not
show the attachments. If you then try to open the email with a double-click,
the program crashes.
Using a Mail3 V1 database.

------- Comment #1 From Thomas Deharde 2012-10-26 07:24:04 -------
Created an attachment (id=65) [details]
Crash Dump File

------- Comment #2 From Matthew Allen 2012-10-26 09:23:00 -------
i.Scribe or InScribe?

------- Comment #3 From Matthew Allen 2012-10-26 09:57:11 -------
I've fixed the size of the sent email with attachments. But I can reproduce the
crash :-(

------- Comment #4 From Thomas Deharde 2012-10-26 11:53:25 -------
Okay.... It's i.scribe. Tried it again and I can reproduce it this way:
1. create an email with an attachment
2. sent it out
3. go to the "send" folder and double-click on the fresh mail (crashes every
time I do this)

Note: It does not crash if I close i.scribe and then open the mail.
Another Note: I tried to "fix" the size of mails by dragging the mail to the
desktop and dropping it back to an i.scribe folder. The eml file on the desktop
was the complete file with the attachments (checked it with an editor), but
when I dropped it to an i.scribe folder, the attachments were gone. This did
not happen with the old mail2 format.

------- Comment #5 From Thomas Deharde 2012-11-19 07:30:10 -------
Looks fixed in version 2 beta 41 and beta 42